Project

General

Profile

Bug #11303

backport -L flag to do_autogen.sh

Added by Alfredo Deza over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/01/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
giant,hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

From Josh:

I'm not sure if lttng is enabled in the release builds right now, but
we should change them to configure --without-lttng for now, for hammer.
There's a bad interaction with libvirt/apparmor/lttng [1] (and I'd
guess selinux too).

This only potentially affects trusty and fedora, since lttng is too old
(<2.4) in other releases.

We can keep it enabled on the gitbuilders so that it's still usable
without making users recompile ceph.

[1] https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1432644

Creating a ticket because the commits that add the flag are full of conflicts

History

#1 Updated by Loic Dachary over 3 years ago

  • Status changed from New to In Progress
  • Backport set to firefly,giant,hammer

#3 Updated by Loic Dachary over 3 years ago

I think the right fix for this issue is to not use do_autogen.sh but autogen.sh + configure.

#4 Updated by Loic Dachary over 3 years ago

  • Backport changed from firefly,giant,hammer to giant,hammer

Removing the firefly backport target: firefly does not have lttng, it's a hack to make it possible to call do_autogen.sh -L although it won't have any effect. This is confusing but harmless. It would have been nice to mention that in the commit message of https://github.com/ceph/ceph/pull/4247

#5 Updated by Alfredo Deza over 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF