Project

General

Profile

Bug #11258

cephfs-java ftruncate unit test failure

Added by Noah Watkins over 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
03/28/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
hammer
Regression:
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Component(FS):
Needs Doc:
No

Description

http://pulpito.ceph.com/teuthology-2015-03-20_23:04:02-fs-master-testing-basic-multi/814833/

2015-03-21T10:22:28.617 INFO:tasks.workunit.client.0.burnupi36.stdout:1) test_ftruncate(com.ceph.fs.CephMountTest)
2015-03-21T10:22:28.647 INFO:tasks.workunit.client.0.burnupi36.stdout:java.lang.AssertionError
2015-03-21T10:22:28.647 INFO:tasks.workunit.client.0.burnupi36.stdout:    at org.junit.Assert.fail(Assert.java:86)
2015-03-21T10:22:28.647 INFO:tasks.workunit.client.0.burnupi36.stdout:    at org.junit.Assert.assertTrue(Assert.java:41)
2015-03-21T10:22:28.647 INFO:tasks.workunit.client.0.burnupi36.stdout:    at org.junit.Assert.assertTrue(Assert.java:52)
2015-03-21T10:22:28.648 INFO:tasks.workunit.client.0.burnupi36.stdout:    at com.ceph.fs.CephMountTest.test_ftruncate(CephMountTest.java:767)

This one might be caused by the previous failing to cleanup.

2015-03-21T10:22:28.656 INFO:tasks.workunit.client.0.burnupi36.stdout:2) com.ceph.fs.CephMountTest
2015-03-21T10:22:28.656 INFO:tasks.workunit.client.0.burnupi36.stdout:java.io.IOException: Directory not empty
2015-03-21T10:22:28.656 INFO:tasks.workunit.client.0.burnupi36.stdout:    at com.ceph.fs.CephMount.native_ceph_rmdir(Native Method)
2015-03-21T10:22:28.656 INFO:tasks.workunit.client.0.burnupi36.stdout:    at com.ceph.fs.CephMount.rmdir(CephMount.java:401)
2015-03-21T10:22:28.657 INFO:tasks.workunit.client.0.burnupi36.stdout:    at com.ceph.fs.CephMountTest.destroy(CephMountTest.java:62)
2015-03-21T10:22:28.657 INFO:tasks.workunit.client.0.burnupi36.stdout:    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2015-03-21T10:22:28.657 INFO:tasks.workunit.client.0.burnupi36.stdout:    at 

Related issues

Duplicated by fs - Bug #13907: libcephfs-java failure on hammer Duplicate 11/30/2015
Duplicated by fs - Bug #16844: hammer: libcephfs-java/test.sh fails Duplicate 07/28/2016
Copied to fs - Backport #13927: hammer: cephfs-java ftruncate unit test failure Resolved

Associated revisions

Revision ccdeaf87 (diff)
Added by Yan, Zheng over 2 years ago

mds: fix out-of-order messages

When MDS is no longer laggy, it should process deferred messages
first, then process newly received messages.

Fix: #11258
Signed-off-by: Yan, Zheng <>

Revision 2332cf22 (diff)
Added by Yan, Zheng 9 months ago

mds: fix out-of-order messages

When MDS is no longer laggy, it should process deferred messages
first, then process newly received messages.

Fix: #11258
Signed-off-by: Yan, Zheng <>
(cherry picked from commit ccdeaf87df8b66e09f6b20950b57ac61bf213086)

History

#1 Updated by Noah Watkins over 2 years ago

I can't reproduce this (re-ran java test suite 100x). The test is:

1. write some data to a file
2. verify fstat reports expected file size
3. ftruncate to smaller size
4. verify fstat reports truncated size (fails)

Possibilities:

1. cephfs bug
2. wrong assumption about behavior of fstat/ftruncate
3. bug in java

I've added some extra code to dump out the sizes that aren't reported as equal. Maybe this will get reproduced in a later run.

#2 Updated by Zheng Yan over 2 years ago

  • Status changed from New to In Progress
  • Assignee changed from Noah Watkins to Zheng Yan

It's a message order issue

#3 Updated by Greg Farnum over 2 years ago

See also #10703 for more info.

#4 Updated by Zheng Yan over 2 years ago

  • Status changed from In Progress to Resolved

#5 Updated by Nathan Cutler over 1 year ago

  • Status changed from Resolved to Pending Backport
  • Source changed from other to Community (dev)
  • Backport set to hammer,infernalis

#6 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #13927: hammer: cephfs-java ftruncate unit test failure added

#7 Updated by Nathan Cutler over 1 year ago

  • Backport changed from hammer,infernalis to hammer

#8 Updated by Nathan Cutler over 1 year ago

  • Duplicated by Bug #13907: libcephfs-java failure on hammer added

#9 Updated by Nathan Cutler about 1 year ago

  • Duplicated by Bug #16844: hammer: libcephfs-java/test.sh fails added

#10 Updated by Nathan Cutler 9 months ago

  • Needs Doc set to No

#11 Updated by Nathan Cutler 9 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF