Project

General

Profile

Bug #11157

autogen.sh must init submodules

Added by Loic Dachary over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
03/18/2015
Due date:
% Done:

80%

Source:
other
Tags:
Backport:
firefly,giant,dumpling
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

https://github.com/ceph/ceph/blob/hammer/autogen.sh#L32 must be backport. Otherwise it's painful to switch from master to firefly because of the submodule changes.

Associated revisions

Revision c7b02f5a (diff)
Added by Loic Dachary over 3 years ago

doc,tests: force checkout of submodules

When updating submodules, always checkout even if the HEAD is the
desired commit hash (update --force) to avoid the following:

  • a directory gmock exists in hammer
  • a submodule gmock replaces the directory gmock in master
  • checkout master + submodule update : gmock/.git is created
  • checkout hammer : the gmock directory still contains the .git from
    master because it did not exist at the time and checkout won't
    remove untracked directories
  • checkout master + submodule update : git rev-parse HEAD is
    at the desired commit although the content of the gmock directory
    is from hammer

http://tracker.ceph.com/issues/11157 Fixes: #11157

Signed-off-by: Loic Dachary <>

Revision cddbff9a (diff)
Added by Loic Dachary over 3 years ago

doc,tests: force checkout of submodules

When updating submodules, always checkout even if the HEAD is the
desired commit hash (update --force) to avoid the following:

  • a directory gmock exists in hammer
  • a submodule gmock replaces the directory gmock in master
  • checkout master + submodule update : gmock/.git is created
  • checkout hammer : the gmock directory still contains the .git from
    master because it did not exist at the time and checkout won't
    remove untracked directories
  • checkout master + submodule update : git rev-parse HEAD is
    at the desired commit although the content of the gmock directory
    is from hammer

http://tracker.ceph.com/issues/11157 Fixes: #11157

Signed-off-by: Loic Dachary <>

Revision c5402db4 (diff)
Added by Loic Dachary over 3 years ago

doc,tests: force checkout of submodules

When updating submodules, always checkout even if the HEAD is the
desired commit hash (update --force) to avoid the following:

  • a directory gmock exists in hammer
  • a submodule gmock replaces the directory gmock in master
  • checkout master + submodule update : gmock/.git is created
  • checkout hammer : the gmock directory still contains the .git from
    master because it did not exist at the time and checkout won't
    remove untracked directories
  • checkout master + submodule update : git rev-parse HEAD is
    at the desired commit although the content of the gmock directory
    is from hammer

http://tracker.ceph.com/issues/11157 Fixes: #11157

Signed-off-by: Loic Dachary <>

History

#1 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#2 Updated by Loic Dachary over 3 years ago

  • Priority changed from Normal to Urgent

#3 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)

#4 Updated by Loic Dachary over 3 years ago

  • Description updated (diff)
  • Status changed from In Progress to Need Review
  • % Done changed from 0 to 80

#5 Updated by Loic Dachary over 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF