Project

General

Profile

Bug #11143

src/ceph-disk : "disk zap" sgdisk invocation

Added by Owen Synge over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
common
Target version:
-
Start date:
03/18/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
firefly, hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

If the metadata on the disk is truly invalid, sgdisk would fail to zero
it in one go, because --mbrtogpt apparently tried to operate on the
metadata it read before executing --zap-all.

This was found as part of QA in SUSE cloud.


Related issues

Copied to Ceph - Backport #11712: src/ceph-disk : "disk zap" sgdisk invocation Resolved 03/18/2015
Copied to Ceph - Backport #11713: src/ceph-disk : "disk zap" sgdisk invocation Resolved 03/18/2015

Associated revisions

Revision fdd7f8d8 (diff)
Added by Owen Synge over 3 years ago

Fix "disk zap" sgdisk invocation

Fixes #11143

If the metadata on the disk is truly invalid, sgdisk would fail to zero
it in one go, because --mbrtogpt apparently tried to operate on the
metadata it read before executing --zap-all.

Splitting this up into two separate invocations to first zap everything
and then clear it properly fixes this issue.

Based on patch by Lars Marowsky-Bree <> in ceph-deploy.
Created by Vincent Untz <>

Signed-off-by: Owen Synge <>
Signed-off-by: Thorsten Behrens <>

Revision 6a04b55d (diff)
Added by Owen Synge over 3 years ago

Fix "disk zap" sgdisk invocation

Fixes #11143

If the metadata on the disk is truly invalid, sgdisk would fail to zero
it in one go, because --mbrtogpt apparently tried to operate on the
metadata it read before executing --zap-all.

Splitting this up into two separate invocations to first zap everything
and then clear it properly fixes this issue.

Based on patch by Lars Marowsky-Bree <> in ceph-deploy.
Created by Vincent Untz <>

Signed-off-by: Owen Synge <>
Signed-off-by: Thorsten Behrens <>
(cherry picked from commit fdd7f8d83afa25c4e09aaedd90ab93f3b64a677b)

Revision 10d85e11 (diff)
Added by Owen Synge over 3 years ago

Fix "disk zap" sgdisk invocation

Fixes #11143

If the metadata on the disk is truly invalid, sgdisk would fail to zero
it in one go, because --mbrtogpt apparently tried to operate on the
metadata it read before executing --zap-all.

Splitting this up into two separate invocations to first zap everything
and then clear it properly fixes this issue.

Based on patch by Lars Marowsky-Bree <> in ceph-deploy.
Created by Vincent Untz <>

Signed-off-by: Owen Synge <>
Signed-off-by: Thorsten Behrens <>
(cherry picked from commit fdd7f8d83afa25c4e09aaedd90ab93f3b64a677b)

History

#1 Updated by Loic Dachary over 3 years ago

  • Status changed from New to Pending Backport
  • Backport set to firefly, hammer

#4 Updated by Nathan Cutler over 3 years ago

  • Status changed from Pending Backport to Resolved
  • Regression set to No

Also available in: Atom PDF