Project

General

Profile

Bug #10728

fedora21 has junit, not junit4

Added by Loic Dachary almost 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/03/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

https://github.com/ceph/ceph/blob/master/ceph.spec.in#L285 should be using junit instead of junit4 for fedora21


Related issues

Copied to devops - Backport #13413: fedora21 has junit, not junit4 Resolved 02/03/2015

Associated revisions

Revision 4f36eaee (diff)
Added by Loic Dachary almost 4 years ago

ceph.spec.in: junit always except for EPEL 6

The package was renamed a long time ago (around the Fedora 15
timeframe). The "junit4" name is only relevant for EPEL 6. For EPEL 7
and Fedora 20, the "junit" package has "Provides: junit4". And most
recently, in the junit package that ships in Fedora 21 and 22, the
package maintainer dropped the old Provides: line.

http://tracker.ceph.com/issues/10728 Fixes: #10728

Signed-off-by: Ken Dreyer <>
Signed-off-by: Loic Dachary <>

Revision 415335df (diff)
Added by Loic Dachary about 3 years ago

ceph.spec.in: junit always except for EPEL 6

The package was renamed a long time ago (around the Fedora 15
timeframe). The "junit4" name is only relevant for EPEL 6. For EPEL 7
and Fedora 20, the "junit" package has "Provides: junit4". And most
recently, in the junit package that ships in Fedora 21 and 22, the
package maintainer dropped the old Provides: line.

http://tracker.ceph.com/issues/10728 Fixes: #10728

Signed-off-by: Ken Dreyer <>
Signed-off-by: Loic Dachary <>
(cherry picked from commit 4f36eaee9ea71ed48018ccb2d7eac3e809c72d82)

History

#1 Updated by Loic Dachary almost 4 years ago

  • Status changed from New to Need Review
  • Assignee set to Loic Dachary

#2 Updated by Loic Dachary over 3 years ago

  • Status changed from Need Review to Resolved

#3 Updated by Nathan Cutler about 3 years ago

  • Status changed from Resolved to Pending Backport
  • Backport set to firefly
  • Regression set to No

#4 Updated by Nathan Cutler about 3 years ago

The Fedora 22 gitbuilder is not building firefly-backports because of this.

#5 Updated by Nathan Cutler about 3 years ago

  • Project changed from Ceph to devops

#6 Updated by Loic Dachary about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF