Project

General

Profile

Bug #10665

RGW swift API: Adding custom metadata to containers using x-container-meta-name is not working.

Added by Ahmad Faheem almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
01/28/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
firefly
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Steps to reproduce:

1. swift post container
2. curl -i https://10.20.20.15:80/swift/v1/container -X POST -H "X-Auth-Token: c12140163cce491e9aed7165796f1f02" -H "x-object-meta-testmeta1: data1"
3. swift stat container

Account: v1
Container: container
Objects: 5
Bytes: 2097152
Read ACL:
Write ACL:
Sync To:
Sync Key:
Server: Apache/2.4.7 (Ubuntu)
X-Container-Bytes-Used-Actual: 2097152
Connection: close
Content-Type: application/octet-stream

As per the link http://ceph.com/docs/master/radosgw/swift/ adding/deleting custom container metadata is supported

Associated revisions

Revision 2f8d31e9 (diff)
Added by Dmytro Iurchenko almost 4 years ago

rgw: Swift API. Dump container's custom metadata.

Fixes: #10665
Backport: hammer, firefly
Reported-by: Ahmad Faheem <>
Signed-off-by: Dmytro Iurchenko <>

Revision 651dc556 (diff)
Added by Dmytro Iurchenko over 3 years ago

rgw: Swift API. Dump container's custom metadata.

Fixes: #10665
Backport: hammer, firefly
Reported-by: Ahmad Faheem <>
Signed-off-by: Dmytro Iurchenko <>
(cherry picked from commit 2f8d31e9b1c4b09506bd1b0dad635c6e820783b2)

Conflicts:
src/rgw/rgw_rest_swift.cc
The first hunk conflicts because X-Storage-Policy was added
after firefly. The second hunk conflicts because the type of the
s->object data member changed after firefly but it is irrelevant
because the patch does not need to access s->object anymore.

History

#2 Updated by Dmytro Yurchenko almost 4 years ago

  • Assignee set to Dmytro Yurchenko

#3 Updated by Dmytro Yurchenko almost 4 years ago

  • Status changed from New to Need Review

#4 Updated by Yehuda Sadeh almost 4 years ago

  • Backport set to firefly

#5 Updated by Yehuda Sadeh almost 4 years ago

  • Backport changed from firefly to firefly, hammer

#6 Updated by Yehuda Sadeh almost 4 years ago

  • Status changed from Need Review to Pending Backport

#7 Updated by Yehuda Sadeh almost 4 years ago

  • Backport changed from firefly, hammer to firefly

#8 Updated by Loic Dachary over 3 years ago

commit:651dc55 rgw: Swift API. Dump container's custom metadata. (in firefly),

#9 Updated by Loic Dachary over 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF