Project

General

Profile

Bug #10353

the number of tries should be higher for the default erasure coded ruleset

Added by Loic Dachary almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
-
Start date:
12/17/2014
Due date:
% Done:

80%

Source:
other
Tags:
Backport:
giant,firefly
Regression:
No
Severity:
4 - irritation
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

It is common for people to try to map 9 OSDs out of a 9 OSDs total ceph cluster. The default tries (50) is often not enough and 200 should be enough. The ruleset created by default should have

             step set_choose_tries 200

to address this case.

Associated revisions

Revision 2f87ac80 (diff)
Added by Loic Dachary almost 4 years ago

crush: set_choose_tries = 100 for erasure code rulesets

It is common for people to try to map 9 OSDs out of a 9 OSDs total ceph
cluster. The default tries (50) will frequently lead to bad mappings for
this use case. Changing it to 100 makes no significant CPU performance
difference, as tested manually by running crushtool on one million
mappings.

http://tracker.ceph.com/issues/10353 Fixes: #10353

Signed-off-by: Loic Dachary <>

Revision 1e58bb49 (diff)
Added by Loic Dachary over 3 years ago

crush: set_choose_tries = 100 for erasure code rulesets

It is common for people to try to map 9 OSDs out of a 9 OSDs total ceph
cluster. The default tries (50) will frequently lead to bad mappings for
this use case. Changing it to 100 makes no significant CPU performance
difference, as tested manually by running crushtool on one million
mappings.

http://tracker.ceph.com/issues/10353 Fixes: #10353

Signed-off-by: Loic Dachary <>
(cherry picked from commit 2f87ac807f3cc7ac55d9677d2051645bf5396a62)

Conflicts:
src/erasure-code/lrc/ErasureCodeLrc.cc
safely ignored because the file does not exist

Revision 5fca2320 (diff)
Added by Loic Dachary over 3 years ago

crush: set_choose_tries = 100 for erasure code rulesets

It is common for people to try to map 9 OSDs out of a 9 OSDs total ceph
cluster. The default tries (50) will frequently lead to bad mappings for
this use case. Changing it to 100 makes no significant CPU performance
difference, as tested manually by running crushtool on one million
mappings.

http://tracker.ceph.com/issues/10353 Fixes: #10353

Signed-off-by: Loic Dachary <>
(cherry picked from commit 2f87ac807f3cc7ac55d9677d2051645bf5396a62)

History

#1 Updated by Loic Dachary almost 4 years ago

  • Backport set to giant,firefly

#2 Updated by Loic Dachary almost 4 years ago

  • Status changed from Verified to Need Review
  • % Done changed from 0 to 80

#3 Updated by Loic Dachary almost 4 years ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Loic Dachary over 3 years ago

  • Tracker changed from Fix to Bug
  • Severity set to 4 - irritation

#5 Updated by Sage Weil over 3 years ago

giant backport done, still waiting on firefly

#6 Updated by Loic Dachary over 3 years ago

5fca232 crush: set_choose_tries = 100 for erasure code rulesets (in giant), 1e58bb4 crush: set_choose_tries = 100 for erasure code rulesets (in firefly),

#7 Updated by Loic Dachary over 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF