Project

General

Profile

Bug #10107

Coredump in upgrade:giant-x-next-distro-basic-multi run

Added by Yuri Weinstein over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/14/2014
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

(Maybe related to #8733)

Logs are in http://qa-proxy.ceph.com/teuthology/teuthology-2014-11-13_17:04:11-upgrade:giant-x-next-distro-basic-multi/600014/

ceph-osd.5.log.gz:2014-11-13 21:53:48.676054 7f7e43ca6700 -1 *** Caught signal (Aborted) **
ceph-osd.5.log.gz: in thread 7f7e43ca6700
ceph-osd.5.log.gz:
ceph-osd.5.log.gz: ceph version 0.88-218-g20f99ca (20f99ca526ae7886a7a505e6c1558c7f413b053c)
ceph-osd.5.log.gz: 1: ceph-osd() [0x9c5da5]
ceph-osd.5.log.gz: 2: (()+0xfcb0) [0x7f7e4f7a9cb0]
ceph-osd.5.log.gz: 3: (gsignal()+0x35) [0x7f7e4de8c425]
ceph-osd.5.log.gz: 4: (abort()+0x17b) [0x7f7e4de8fb8b]
ceph-osd.5.log.gz: 5: (__gnu_cxx::__verbose_terminate_handler()+0x11d) [0x7f7e4e7df69d]
ceph-osd.5.log.gz: 6: (()+0xb5846) [0x7f7e4e7dd846]
ceph-osd.5.log.gz: 7: (()+0xb5873) [0x7f7e4e7dd873]
ceph-osd.5.log.gz: 8: (()+0xb596e) [0x7f7e4e7dd96e]
ceph-osd.5.log.gz: 9: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x259) [0xaafb49]
ceph-osd.5.log.gz: 10: (FileStore::_collection_move_rename(coll_t, ghobject_t const&, coll_t, ghobject_t const&, SequencerPosition const&)+0xda6) [0x8c39c6]
ceph-osd.5.log.gz: 11: (FileStore::_do_transaction(ObjectStore::Transaction&, unsigned long, int, ThreadPool::TPHandle*)+0xb49) [0x8c6919]
ceph-osd.5.log.gz: 12: (FileStore::_do_transactions(std::list<ObjectStore::Transaction*, std::allocator<ObjectStore::Transaction*> >&, unsigned long, ThreadPool::TPHandle*)+0x64) [0x8cbe44]
ceph-osd.5.log.gz: 13: (FileStore::_do_op(FileStore::OpSequencer*, ThreadPool::TPHandle&)+0x297) [0x8cc0f7]
ceph-osd.5.log.gz: 14: (ThreadPool::worker(ThreadPool::WorkThread*)+0x48e) [0xa9ef1e]
ceph-osd.5.log.gz: 15: (ThreadPool::WorkThread::entry()+0x10) [0xaa1cb0]
ceph-osd.5.log.gz: 16: (()+0x7e9a) [0x7f7e4f7a1e9a]
ceph-osd.5.log.gz: 17: (clone()+0x6d) [0x7f7e4df4a3fd]
ceph-osd.5.log.gz: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

Related issues

Duplicates Ceph - Bug #10059: osd/ECBackend.cc: 876: FAILED assert(0) Resolved 11/10/2014

History

#1 Updated by Sage Weil over 4 years ago

    -8> 2014-11-13 21:53:48.529521 7f7e43ca6700 15 filestore(/var/lib/ceph/osd/ceph-5) setattrs 3.12s3_head/2ced7b32/plana235437-45/head//3/18446744073709551615/3
    -7> 2014-11-13 21:53:48.529532 7f7e43ca6700 10 filestore oid: 2ced7b32/plana235437-45/head//3/18446744073709551615/3 not skipping op, *spos 6224.0.24
    -6> 2014-11-13 21:53:48.529535 7f7e43ca6700 10 filestore  > header.spos 0.0.0
    -5> 2014-11-13 21:53:48.529554 7f7e43ca6700 10 filestore(/var/lib/ceph/osd/ceph-5) setattrs 3.12s3_head/2ced7b32/plana235437-45/head//3/18446744073709551615/3 = 0
    -4> 2014-11-13 21:53:48.529561 7f7e43ca6700 15 filestore(/var/lib/ceph/osd/ceph-5) touch 3.12s3_head/2ced7b32/plana235437-45/head//3/18446744073709551615/3
    -3> 2014-11-13 21:53:48.529566 7f7e43ca6700 10 filestore(/var/lib/ceph/osd/ceph-5) touch 3.12s3_head/2ced7b32/plana235437-45/head//3/18446744073709551615/3 = 0
    -2> 2014-11-13 21:53:48.529572 7f7e43ca6700 15 filestore(/var/lib/ceph/osd/ceph-5) _collection_move_rename 3.12s3_head/2ced7b32/plana235437-45/snapdir//3/609/3 from 3.12s3_head/2ced7b32/plana235437-45/snapdir//3/18446744073709551615/3
    -1> 2014-11-13 21:53:48.529609 7f7e43ca6700 10 filestore(/var/lib/ceph/osd/ceph-5) error opening file /var/lib/ceph/osd/ceph-5/current/3.12s3_head/plana235437-45__snapdir_2CED7B32__3_ffffffffffffffff_3 with flags=2: (2) No such file or directory
     0> 2014-11-13 21:53:48.532574 7f7e43ca6700 -1 os/FileStore.cc: In function 'int FileStore::_collection_move_rename(coll_t, const ghobject_t&, coll_t, const ghobject_t&, const SequencerPosition&)' thread 7f7e43ca6700 time 2014-11-13 21:53:48.529622
os/FileStore.cc: 4880: FAILED assert(replaying)

 ceph version 0.88-218-g20f99ca (20f99ca526ae7886a7a505e6c1558c7f413b053c)
 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x7f) [0xaaf96f]
 2: (FileStore::_collection_move_rename(coll_t, ghobject_t const&, coll_t, ghobject_t const&, SequencerPosition const&)+0xda6) [0x8c39c6]
 3: (FileStore::_do_transaction(ObjectStore::Transaction&, unsigned long, int, ThreadPool::TPHandle*)+0xb49) [0x8c6919]
 4: (FileStore::_do_transactions(std::list<ObjectStore::Transaction*, std::allocator<ObjectStore::Transaction*> >&, unsigned long, ThreadPool::TPHandle*)+0x64) [0x8cbe44]
 5: (FileStore::_do_op(FileStore::OpSequencer*, ThreadPool::TPHandle&)+0x297) [0x8cc0f7]
 6: (ThreadPool::worker(ThreadPool::WorkThread*)+0x48e) [0xa9ef1e]
...

#2 Updated by Samuel Just over 4 years ago

  • Assignee set to Samuel Just

#3 Updated by Samuel Just over 4 years ago

  • Status changed from New to Duplicate

I think this is caused by the same thing as 10059, duplicate marking.

Also available in: Atom PDF